Ask a Flooder 15: How do I install Element? [Video]

Downloading and installing Flood's open-source Puppeteer-based load testing tool

In this Flood Element tutorial, Nicole shows the steps required to install Element, including dependencies it requires. Flood Element is an open-source browser-based load testing tool created by Tricentis Flood.

Learn more about Flood Element
Installation instructions for NodeJS
Installation instructions for Yarn
Installation instructions for Element
Video: Getting Started with Element
Guides: Using Element with Flood

Transcript

Hi everyone, Nicole van der Hoeven here again, back with another Ask a Flooder, and today's question is: "How do I install Element?"

Now, I already made a previous video on how to get started with Element, but I didn't actually go into the details of how to install it, so that's what I'm going to do in this video today. There are actually a few parts to installing Element, and all of these instructions are going to be on element.flood.io. If you go onto the site and click on Install, you'll see all of the instructions depending on which operating system you're on.

First, you need to install NodeJS. This is sort of like how, if you're familiar with JMeter, you have to install Java before installing JMeter. NodeJS is what Element runs on. Secondly, you'll need a package manager. You can use NPM or Yarn, but in this video, I'm going to take you through how to do it with Yarn. And thirdly, there's installing Element itself.

First, download NodeJS. I'm going to leave links in the description to all of the sites that I visit so that you can go through all of the instructions later. On the Node site, download whichever installer suits your operating system. Go through the installation steps, and afterwards, check to make sure that NodeJS is properly installed on your machine. You can do that by going into the terminal and typing:

js
node -v

Just make sure that the version that's shown here is the same version that you've downloaded.

Secondly, install the latest version of Yarn. On the Yarn site, you're going to have to choose your operating system and the version. We recommend using the latest stable version. And then go through the instructions for your operating system. After you've done that, check your Yarn installation by typing:

js
yarn --version

And the last step is installing Element. On the Element site, you can find the exact code that you need to type into your terminal. It's:

js
yarn global add @flood/element-cli

So you can just copy that into your terminal. As of the time of this recording, the latest version of Element is 1.2.3. Looks like that's installed. To check the version of Element, type:

js
element --version

So that's how to install Element. We've gotten a lot of questions recently about Element in particular, so I'm going to answering them in future videos. Hope this helped, and until next time, happy flooding!

Start load testing now

It only takes 30 seconds to create an account, and get access to our free-tier to begin load testing without any risk.